How to solve Google Maps/Waze issues on Android Auto

This is not the typical O365VoiceLab post, but hey… sharing is caring šŸ™‚

My wife and I are really enjoying our brand new car and so does Jax, our puppy who finnaly has a complete “living room” in the trunk šŸ™‚

All nice and dandy until trying to use the Google Maps or Waze app through Android Auto and here comes the pain. The app behaves like it wouldn’t have proper GPS coverage, constantly repositioning, recalculating the route and flipping the map round and round…

Was just about to give up and buy a phone holster so I can use the maps apps in the old fashioned method, when it striked me… Why does Android Auto needs access to my Location service? If i’m already mirroring a location application which naturally has access to the location, why would i grant the same permission to Android Auto.

With this in mind, i went to Settings -> Apps -> Tap on Android Auto -> Tap on Permissions -> Select Location -> Tap on Deny Access. MAGIC, my problem dissapeared!

Seems that denying access to the location service for the Android Auto app, forces it to levrage the location service from the maps app itself which instantly mitigates the issue.

Hope you enjoyed the read and found some good advice here.

Meanwhile, safe travels and continue researching, learning and trubleshooting!

Sabin

  1. Roma

    Looks I have the same issue, Tucson NX4 hybrid with Android Auto, without built-in navigation. I made the videos and uploaded it to youtube, can you check is it the same?
    https://youtu.be/4AhtWRgVS5o
    https://youtu.be/i_33Bs1L0Kw
    https://youtu.be/kM2VDqNc1uo
    https://youtu.be/HUrl-YfFDdo

    Also I wrote yersterday to Android Auto community. Waiting for the response.
    https://support.google.com/androidauto/thread/119184141/google-maps-infinitely-rebuilding-route-gps?hl=en

    That issue also annoying my wife šŸ™ we dont know what is the real root cause: is this a head unit or Android Auto app in the phone? We have another older Tucson 2019, and we never faced any issues with Android Auto Google Maps and Wase

    1. Sabin

      Yes, seems to be exact same behavior. Have you tested the steps i listed in the article? That should help you.

      1. Roma

        Yes, we have. And it helped!!! Thank you a lot for that trick! We still communicate with car dealership, reporting to them that issue, we would like that they investigate that issue

        1. Sabin

          You are most welcome. Happy it helped.
          As a side note, i have also shared this information with my car dealership but it didn’t raise much interest to them šŸ™‚
          While this is not manufacturor issue but an Android one, they should be able to provide such answers to other affected users.

          1. Merdas

            I have exact same issue with my Hyundai Tucson and this helped me fix it temporarily, but I don’t think this is Android Auto issue as AA doesn’t use phone GPS when it can and I have no issue with the same phone in another car,

            I had a hard time at the dealership describing the issue and they kept denying that this is a fault from the car!

  2. Sabin

    Honestly, i doubt this is a Tucson issue. I am getting feedback from other folks that same issue appears on other cars.
    Would be interesting if you could update this thread if you manage to get some sort of acknowledgment from the dealership.

  3. Augusto

    Hi Sabin, thanks for the post very helpful. I will try that in my Tucson to see if it works.
    I have the exact same issue.
    My Tucson Model is NX4N20S.DVAMN.F1AU and my head unit software version is NX4.AUS.D2V.001.002.201130. I have a friend with the exact same model of Tucson and he was having the same issue. He updated his head unit software and the problem was solved. His new software version is NX4.AUS.D2V.001.002.210603. I’ve tried to update my software at the dealer, but they said they don’t have this update šŸ™
    Hopefully, Hyundai fixes this soon.

    1. Sabin

      Hi Augusto,
      Hope this will help to get your issue fixed. Looking forward for your update šŸ™‚
      Meanwhile, enjoy this awesome head-turning car šŸ™‚

  4. Mohammad

    Hi,
    Looks like Hyundai released a few software update in different regions including the Tucson Hybrid,

    Is it possible for you to check if there is an update for your car and whether that can fix the issue?

    https://update.hyundai.com/

    There is no update available for my region unfortunately to test!

    Thank you,

    1. Sabin

      Hi Mohammad,
      The link you shared is for the navigation update (the large media version). My car doesn’t have sat nav, so I cannot install any update from this link unfortunately.

  5. Frankye

    Hi, I have a brand new Tucson 2022 with the same issues both with iOS 15 (iPhone 12) and Android (Samsung S21 Ultra). Both phones disconnected from the car run perfectly the maps apps but when connected to my Tucson (via wifi, the only option in my Tucson) both maps in CarPlay and Android Auto go crazy. I think it’s a problem with the Tucson subsystem.

    1. RamPc

      Iā€™m located in Costa Rica and issue happen with my Tucson 2022 – 500 Km. Its not appear an issue of the area (since we are located in different places) it appears more something with the car. Either with the software or the gps.

      Did anyone get a real solution?

Leave a Reply to Roma Cancel reply

Your email address will not be published. Required fields are marked *

This site uses Akismet to reduce spam. Learn how your comment data is processed.